Legal Notices

Copyright © 2005-2016 Synacor, Inc. All rights reserved. This product is protected by U.S. and international copyright and intellectual property laws. “Zimbra” is a registered trademark of Synacor, Inc. in the United States and other jurisdictions. You may not alter or remove any trademark, copyright, or other notice from copies of the content. All other marks and names mentioned herein may be trademarks of their respective companies.

Synacor, Inc.
40 La Riviere Drive, Suite 300
Buffalo, New York 14202

www.synacor.com

Zimbra Collaboration 8.7

April 2016
# Table of Contents

1 About ZCO .......................................................... 5
   Use ZCO with the Correct Version of Zimbra Collaboration ........... 5
   Supported Versions of Microsoft Operating System ...................... 5
   Supported Versions of Microsoft Outlook ............................... 6
   ZCO Files .................................................................... 6
      Obtaining the ZCO Files ............................................. 7
      Running Customization and Branding Scripts ....................... 7

2 Preconfiguring and Customizing the Installer .......................... 9
   Overview of the Customization Process .................................. 9
   Adding ZCO Server Credentials ....................................... 10
   Additional Customization of ZCO ...................................... 11
      Set the Password Rule .............................................. 11
      Modify the GAL Sync Mode ........................................ 11
      Location of Local Failure Messages ............................... 11
   Setting Up the Single Sign-On Option (SSO) ........................... 11
   Disabling the Auto-Upgrade Feature ................................... 12
   Hiding Email Aliases in the GAL ...................................... 12
   Setting the ZCO Display Language ..................................... 12
   Rebranding ZCO .......................................................... 13

3 Installing ZCO .......................................................... 15
   Installation Prerequisites .............................................. 15
   Using Secure Connection (SSL) ....................................... 15
   Using Two-step Authentication ........................................ 16
   Using Certificate Authentication ....................................... 16
   Installing ZCO on Individual Computers ............................... 16
   Synchronizing ZCO with Outlook ..................................... 17
      Synchronization Frequency ......................................... 17
      Resyncing the GAL for Contact Group Support .................... 18

4 Zimbra Features in Outlook ............................................. 19
   Personal Email Certificates (S/MIME) .................................. 20
   Advanced Settings ...................................................... 20
   Zimbra Feature Differences for Outlook Users ......................... 21
      Free/Busy Lookup in ZCO ........................................... 21
      Outlook AutoArchive Disabled for Zimbra Profiles and Folders .... 21
      Forwarding Invitations ............................................. 21

5 Troubleshooting ZCO .................................................... 23
   Troubleshooting Overview ............................................. 23
   Received a Local/Server Failure Notice ................................ 24
   Reviewing Sync Issues folders ........................................ 24
   Enabling Logging ...................................................... 25
   When Outlook Crashes ............................................... 26
When Outlook Hangs ........................................... 26
My Zimbra Calendar will not Sync .......................... 26
Unable to Access a Shared Item ............................ 26
The .zdb File is Corrupt ..................................... 26
Conflict with Antivirus Software or other Outlook Add-ins 26
Repairing ZCO .................................................. 27
Removing ZCO .................................................. 27
Resolving Mailbox Sync Problems ......................... 27
Resyncing GAL for Contact Group Support ............... 27
Zimbra Support Toolbar and Zimbra Ribbon ............. 28
  View MAPI Properties ....................................... 28
  Open Original Source ...................................... 28
  View IDs of Zimbra Activities ............................ 28
  Set Sync Token ............................................. 28
Zimbra Support and Additional Resources ................ 29
  Additional Resources ....................................... 29
  Contact Zimbra Support ................................... 29
1 About ZCO

The Zimbra Connector for Microsoft® Outlook® (ZCO) allows users to access their Zimbra Collaboration account using Microsoft Outlook.

ZCO creates a copy of the account data on the user's computer in a file called a ZDB and uses a synchronization mechanism to keep synchronized with the server copy. Items that are synchronized include email messages, folders, tags, contacts, personal calendars, appointment reminders, and tasks.

This chapter includes information about prerequisites for installing ZCO and how to download the ZCO installation file.

Use ZCO with the Correct Version of Zimbra Collaboration

The version of ZCO and Zimbra Collaboration must be from the same major release. For example ZCO 8.x and Zimbra Collaboration 8.x are used together. Never use versions that do not align together, such as ZCO 7.x with Zimbra Collaboration 8.x.

New users typically obtain the ZCO installer from:

https://<servername>/downloads/index.html

ZCO's auto-upgrade function can be used to keep up to date with the latest version. Auto-upgrade checks whether a more recent version of ZCO is available at the above location when Outlook is started, and an upgrade is offered if available.

You can use the Zimbra administration console > Tools and Migration > Client Upload to upload the latest version of ZCO to the above location.

Supported Versions of Microsoft Operating System


Important: Windows XP is deprecated. The 8.x series of Zimbra Collaboration is the last release to support Microsoft Outlook 2003 and Microsoft Windows XP.
Supported Versions of Microsoft Outlook

ZCO supports the following versions of Microsoft Outlook:

**Important:** If Outlook is upgraded, ZCO must be uninstalled and reinstalled. This is particularly important following an upgrade to OL2013, as ZCO needs to be installed to a different location on the client computer.

- Outlook 2016: 32-bit and 64-bit editions of Microsoft Office are supported.
- Outlook 2013: 32-bit and 64-bit editions of Microsoft Office are supported.
- Outlook 2010: 32-bit and 64-bit editions of Microsoft Office are supported.

**Note:** “Click to run” versions of Outlook 2010 are not supported.

- Outlook 2007: Client computers must have Microsoft Office Outlook 2007 SP2 or later installed.
- Outlook 2003: Client computers must have Microsoft Office Outlook 2003 SP3 or later installed. **Important:** Outlook 2003 is deprecated: The 8.x series of Zimbra Collaboration is the last release to support Microsoft Outlook 2003 and Microsoft Windows XP.

ZCO Files

ZCO comprises of the following files:

- **Zimbra Connector for Outlook:** This is the main installation file and is available in 32-bit and 64-bit versions, each in signed and unsigned variants.

- **Zimbra Connector for Outlook MSI Customizer:** ZmCustomizeMsi.js allows the ZCO MSIs to be customized so when the user installs ZCO, it automatically sets certain options such as the server name. For more information, see Running Customization and Branding Scripts on page 7.

- **Zimbra Connector for Outlook Branding MSI Customizer:** Zimbra Connector for Outlook Branding MSI.vbs allows the MSIs to be branded. Branding replaces all instances of the Zimbra product name and logo with that of your company. For more information, see Running Customization and Branding Scripts on page 7.
Obtaining the ZCO Files

The ZCO files are located on the Zimbra Collaboration server in:

/opt/zimbra/jetty-distribution-<version>/webapps/zimbra/downloads/ZimbraConnectorOLK_<version>.msi

Your users can access the appropriate MSI using the following URL:

https://<servername>/downloads/index.html

Or, you can choose to make the MSI available at some other location on your network.

**Note:** Users must have temporary administrator privileges on their computer to install ZCO.

You can also obtain the MSI from the Zimbra Utilities Downloads page in the Zimbra Collaboration administration console:

Home > Tools and Migration > Downloads

**Note:** It is only possible to obtain signed versions of the MSI using administration console.

Running Customization and Branding Scripts

The customization and branding scripts should be run on the unsigned version of the ZCO MSI, which will have a name in the form

ZimbraConnectorOLK_n.n.n.nnnn_xnn-UNSIGNED.msi and is located alongside the signed ZCO MSI in the Downloads folder.

When customization is complete you should rename your modified unsigned MSI to that of the signed version, for example,

ZimbraConnectorOLK_n.n.n.nnnn_xnn.msi and use it to replace the original signed version in the Downloads folder.
2 Preconfiguring and Customizing the Installer

There are two parts to configuring ZCO: installation and creation of a MAPI profile. Creation of a MAPI profile requires the user to enter information such as the server name and their connection security option. To eliminate this step, you can customize the MSI so that it sets these and other options automatically.

To customize the installer with your specific configuration details, you run the `ZmCustomizeMsi.js` file which is located in the Zimbra download directory on the administration console.

Areas that can be customized include:

- Configuring the Zimbra Collaboration server name and secure connection options. When users install ZCO they only need to enter their account name and password.
- Single Sign-on options when SPNEGO is configured.
- Password rules.
- GAL sync mode.
- Default profile name.
- Disabling automatic upgrading to the latest ZCO version.
- Change the Zimbra branding to your own company name or brand using the rebranding tool.

**Note:** To see a complete list of customization options, type `ZmCustomizeMsi` at the command line prompt and press Enter.

**Overview of the Customization Process**

1. Obtain the unsigned MSIs. To customize the installer, you must use `ZmCustomizeMsi.js` to modify the unsigned MSI file. (Customizing the signed MSI file is seen as tampering by the Windows code signing mechanism, and will present your users with a warning at installation time.)
   The unsigned MSIs are available at:
   `/opt/zimbra/jetty-distribution-<version>/webapps/zimbra/downloads`

2. Customize the MSIs according to the sections described in this chapter.
3. (Optional) Sign the MSIs with your own company’s signing certificate.

4. Place the modified MSIs back on the server. You can either place them in the above directory or use the Zimbra Collaboration administration console to upload them: **Home > Tools and Migration > Do Client Upload**

5. Generate a new index.html by either restarting the Zimbra Collaboration server or running `/opt/zimbra/libexec/zmupdatedownload`.

### Adding ZCO Server Credentials

When you add the server name, port, and secure connection details, users only need to add their name and password when they install ZCO.

1. From the administration console, copy the `ZmCustomizeMsi.js` file and the ZCO `.msi` file to a computer running the Windows platform.

2. Open the Windows command prompt.

3. Change to the directory where the `ZmCustomizeMsi.js` file is located.

4. Type the server configuration command all on one line:
   
   ```
   cscript ZmCustomizeMsi.js <path/msi-filename> -sn <servername.com> -sp <port> -ssl <1 | 0> //nologo
   ```

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>ZmCustomizeMsi.js</code></td>
<td>Name of the js file</td>
</tr>
<tr>
<td><code>path/msi-filename</code></td>
<td>Directory path and the ZCO <code>.msi</code> filename.</td>
</tr>
<tr>
<td><code>servername.com</code></td>
<td>Zimbra server name (DNS) to be configured.</td>
</tr>
<tr>
<td><code>port</code></td>
<td>Port number to be configured. For non-secured connections, the default is 80. For a secured connection, the default is 443. Your configuration can be different.</td>
</tr>
<tr>
<td>`1</td>
<td>0`</td>
</tr>
</tbody>
</table>

5. Press Enter. The ZCO `.msi` file is modified.

6. To verify that the modification is correct, run the `.msi` installer and create a dummy profile. The Zimbra Server Configuration Settings dialog should include the server name, server port, and the check box marked/unmarked for whether to use a secure connection.

   You can now make the customized ZCO `.msi` file available to users by placing them back on the server.
Additional Customization of ZCO

You can make other changes to the .msi file to add or modify the following functionality:

Set the Password Rule

1. To set the password rule, enter as `-pw <1|0>

   Setting the password rule to 0 prevents the ZCO password from being saved. This option should be used when using single sign-on (SSO) authentication.

   When the password rule is set to 1, the ZCO encrypted password is saved in the user’s ZCO profile (default).

Modify the GAL Sync Mode

1. To set GAL sync mode, enter as `-gsm <2|1|0>

2. Enter 2 to disable GAL sync; 1 to make GAL sync a manual option only, 0 to enable manual and automatic GAL syncs. Automatic GAL syncs occur whenever the mailbox is synchronized (typically when the user presses F9, or as specified in Outlook Send/Receive Groups configuration).

Location of Local Failure Messages

A Local Failure Message is a message that is created in Outlook when a problem occurs during synchronization. By default, these are created in the Inbox. The Local Failure Messages are not synchronized to the server.

Setting Up the Single Sign-On Option (SSO)

Note: To use SSO, SPNEGO must be configured on Zimbra Collaboration.

SSO works with a specific server. The server name used in the ZCO profile must match that in the SPNEGO configuration. Make sure that the server name is incorporated into the .msi file prior to installation of ZCO.

1. Set the server name to be the server name configured for SPNEGO, enter `-sn <spnegoserver.example.com>

2. Set the password rule, enter `-pw 0

Example:

cscript ZmCustomizeMsi.js <path/msi-filename> -sn <spnegoserver.example.com> -pw 0

For more information, see Appendix B, Configuring SPNEGO Single Sign-On for Zimbra Collaboration in the Zimbra Collaboration Administrator Guide.
Disabling the Auto-Upgrade Feature

When a user launches Outlook, ZCO checks Zimbra Collaboration for a newer version of ZCO. If a newer version is available, the user is prompted with the option to upgrade.

You can disable the auto-upgrade feature. Run the `ZmCustomizeMsi.js` file before installation and select the `--disable-autoupgrade` option.

Hiding Email Aliases in the GAL

By default, ZCO takes a copy of the Zimbra Collaboration’s Global Address List (GAL) and stores it in the ZDB, making it available to Outlook as an Address Book. By default, accounts which have an alternate email address, also known as an alias, will result in multiple entries in the GAL.

If you do not want aliases to appear in the GAL, you can disable this option. Run the `ZmCustomizeMsi.js` file before installation and select the `--galsync-disablealiases 1` option.

When this is disabled, users cannot search for aliases when addressing mail.

Note that a change to this value will not take effect on a particular client until the user resets their GAL. To reset the GAL:

- For Outlook 2003/07 go to Tools > Send/Receive > Global Address List > Reset Global Address List
- For Outlook 2010 and later versions go to Zimbra > Sync Global Address List > Reset Global Address List

Setting the ZCO Display Language

By default ZCO matches its display language to that of the Outlook display language you are using. You can override this by running `ZmCustomizeMsi.js` with the `--lang <LCID>` option, where `<LCID>` is the decimal LCID value of the language you want to display (1033 for US English, 1041 for Japanese, etc.).

This is essential if you want to use ZCO's French Canadian translations for example (since there is no corresponding French Canadian edition of Outlook), in which case the LCID should be 3084.

A individual user can also set the display language via the Language option on ZCO’s Advanced Settings dialog.

Other supported languages include Arabic, Basque, Chinese (Simplified PRC, Traditional HK, and Traditional TW), Danish, Dutch, English, French, French Canadian, German, Hebrew, Hindi, Hungarian, Indonesian, Italian, Japanese, Korean, Lao, Malay, Polish, Portuguese (Brazil and Portugal), Romanian, Russian, Slovenian, Spanish, Swedish, Thai, Turkish, and Ukrainian.

Note that the language used during ZCO installation is based on the current Windows locale.
Rebranding ZCO

You can change the Zimbra branding in ZCO to your own company name or brand.

1. From the administration console, click Downloads link.

2. Open the Zimbra Connector for Outlook Branding MSI.vbs (Visual Basic) file.

3. At the start of the script, replace “Foobar” with your company name or value:

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brand</td>
<td>Substitutes all occurrences of “Zimbra” in the product, except the Zimbra copyright statement in the ZCO About window. (maximum 30 characters)</td>
</tr>
<tr>
<td>Company</td>
<td>Appears only in the .msi file’s summary information (right-click and select Properties) and in the Control Panel entry for the installed program under Publisher. (no character limit)</td>
</tr>
<tr>
<td>DefaultProfileName</td>
<td>Provides a name for the default Outlook profile to be created as part of the installation if none already exists. (maximum of 64 characters)</td>
</tr>
<tr>
<td>AboutLink</td>
<td>The URL that appears in the Control Panel entry for the installed program under Support Link. (no character limit)</td>
</tr>
<tr>
<td>DocumentLink</td>
<td>The Click here for documentation link on the ZCO About dialog. This normally links to a Zimbra PDF document but can be redirected to your own web documents. (maximum of 260 characters)</td>
</tr>
</tbody>
</table>

4. Run this script on the ZCO .msi file that users will use to install ZCO:

   cscript ZimbraBrandMsi.vbs ZimbraOlkConnector.msi

   If ZCO has been previously installed on the target machine, uninstall ZCO before running the newly branded installation.

Your company name or value now replaces the Zimbra brand, and the Zimbra icon is replaced with a generic icon.

Note: Existing Outlook profiles created using the unbranded package should remain usable but will show the old “Zimbra - ...” store name.
3 Installing ZCO

This chapter provides information about what server configuration information the user needs to install ZCO, what takes place when ZCO is installed on individual computers, and what happens during the initial synchronization of ZCO and Outlook.

Installation Prerequisites

If you did not modify the .msi file, the user needs the following server configuration information during the installation process. Be sure to provide this information to your user before they install ZCO so they can complete their installation of ZCO:

- Zimbra Collaboration server name.
- Whether to select Use Secure Connection (SSL). This feature is used to establish a secure connection to that port. See Using Secure Connection (SSL) below.
- The user’s complete email address and email password.

Using Secure Connection (SSL)

When using a secure connect, SSL, all connections that ZCO makes with the server will use SSL to verify the server and encrypt the data.

For this to function properly, consider the following:

- `zmtlsctl` must be set to HTTPS on the server (this is the default setting for 8.0.7 and later). For more information about `zmtlsctl`, see the Zimbra Collaboration Administrator Guide.

- The server must have a valid SSL certificate. See “Managing SSL Certificates for Zimbra Collaboration” in the Zimbra Collaboration Administrator Guide.

- Default Zimbra Collaboration installations generate their own self-signed certificate. This can be used, although in order for ZCO to trust it, the root CA certificate that signed it must be placed in the “Trusted Root Certificate Authorities” section of the Windows Certificate store. This can be done as described in the Zimbra Wiki page ZCO Connection Security. Failure to place the root CA certificate in the “Trusted Root Certificate Authorities” will result in ZCO displaying a warning that the certificate could not be verified.
Using Two-step Authentication

Two-step authentication can be enabled for an individual user account via the Two Factor Authentication section in the Zimbra Admin Console’s Advanced settings.

The user will then need an authentication app (e.g. www.authy.com) installed on the user’s computer or smartphone which can be used to generate time-limited passcodes. The user is prompted to enter a passcode in Outlook whenever ZCO signs onto the Zimbra server.

Initial setup of the authentication app for an individual user should be performed using the Zimbra Web Client (after which, passcodes from the app are equally usable with either ZCO or ZWC):

1. Sign onto ZWC using the user's normal credentials.
2. Under ZWC’s Preferences tab select Accounts.
3. From the Primary Account Settings, select Set up two-step authentication....
4. Follow the setup wizard instructions, supplying a passcode from the authentication app when prompted.

Using Certificate Authentication

Client certificate authentication requires a suitable individual client certificate to be installed in the Personal section of the end user's Windows Certificate store on the computer running Outlook. The certificate generation process itself is the same as that required for ZWC - see the Zimbra Wiki page Client Cert Auth using X.509 for more details.

When configuring a ZCO profile for certificate authentication the port number which has been set in zimbraMailSSLCertCertPort. currently needs to be specified alongside the server name. Hence it makes sense to customize the ZCO installation MSI to incorporate this port number and the corresponding server name before deploying the ZCO MSI (see Adding ZCO Server Credentials on page 10).

Installing ZCO on Individual Computers

It only takes a few minutes for users to install ZCO on their computers and configure the connection to Zimbra Collaboration. You must provide the user with temporary administrative privileges and the server configuration information.

Installing ZCO on a computer which has no existing MAPI profiles results in the creation of a new profile called Zimbra.

The installation does not remove any previous Outlook profiles or accounts. The user can view previous profiles by navigating to Start > Settings > Control
Panel > Mail > Show Profiles. Mail profiles can combine a Zimbra account with an IMAP, Exchange, or POP account.

To add a new profile, users select Add on the Show Profiles dialog and follow the prompts.

**Note:** Users cannot add more than one Zimbra account to a profile. Users can customize the name of the profile created during the installation using the “profile name” customization option available from the installation file.

For more information about the ZCO installation process, see the *Zimbra Connector for Microsoft Outlook User Guide*.

**Synchronizing ZCO with Outlook**

The first time a user opens Outlook after ZCO is installed, the user’s Outlook mailbox must synchronize with Zimbra Collaboration. If users have been using the Zimbra Web Client and have email messages, folders, tags, signatures, contacts, personal calendars, appointment reminders, and tasks on Zimbra Collaboration, this information is synchronized with their Zimbra profile in Outlook.

The initial synchronization can take a few minutes or longer, depending on the size of the mailbox and the network speed. On slow networks, the initial synchronization can take several hours. It is advantageous to install ZCO while using a fast and reliable company network. It is also strongly advised that Antivirus is disabled during the initial sync, otherwise the Antivirus software can prolong the initialization by virus checking messages as they are placed in the ZDB.

If users use the default Zimbra profile, their synchronized data is saved in the *zimbra.zdb* file located in the user’s Local Settings\Application Data\Microsoft\Outlook folder.

**Important:** When Zimbra Collaboration is restored from a Zimbra backup, ZCO profiles might have to be recreated.

**Synchronization Frequency**

ZCO synchronizes automatically as follows:

- At the frequency specified in Outlook’s Send/Receive Groups dialog box (default is 30 minutes)
- When a change is detected on the server or in Outlook
- When the user presses F9
Resyncing the GAL for Contact Group Support

To obtain full support for contact groups for profiles that were created with older versions of ZCO, it is necessary to perform a full GAL reset on your ZCO client to ensure contact groups and their members are synced correctly with Zimbra Collaboration.

- For Outlook 2003/07 go to Tools > Send/Receive > Global Address List > Reset Global Address List
- For Outlook 2010 and later versions go to Zimbra > Sync Global Address List > Reset Global Address List

For more information about ZCO synchronization, see the Zimbra Connector for Microsoft Outlook User Guide.
Zimbra features have been incorporated into Outlook menus. The *Zimbra Connector for Outlook User Guide*, which is available from the ZCO About page describes these features, which include

<table>
<thead>
<tr>
<th>Feature</th>
<th>Location in Outlook</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zimbra Personas</td>
<td>• Available in Outlook 2003/07 under <strong>Tools &gt; Options &gt; Personas.</strong>&lt;br&gt;• Available in Outlook 2010 onwards under <strong>Zimbra &gt; Personas.</strong></td>
</tr>
<tr>
<td>Zimbra Mail Filters</td>
<td>• Available in Outlook 2003/07 under <strong>Tools &gt; Zimbra Server Rules.</strong>&lt;br&gt;• Available in Outlook 2010 onwards under <strong>Zimbra &gt; Zimbra Server Rules.</strong></td>
</tr>
<tr>
<td>Out-of-Office Reply</td>
<td>• Available in Outlook 2003/07 under <strong>Tools &gt; Zimbra Out of Office Assistant.</strong>&lt;br&gt;• Available in Outlook 2010 onwards under <strong>Zimbra &gt; Zimbra Out of Office Assistant.</strong></td>
</tr>
<tr>
<td>Zimbra Tags</td>
<td>Synchronized with Outlook Categories.</td>
</tr>
<tr>
<td>Zimbra mailbox quota</td>
<td>• Available in Outlook 2003/07, can be checked using <strong>Tools &gt; Mailbox Quota.</strong>&lt;br&gt;• Available in Outlook 2010 onwards, can be checked using <strong>Zimbra &gt; Mailbox Quota.</strong></td>
</tr>
<tr>
<td>Enable/disable and update the GAL</td>
<td>• In Outlook 2003/07, enable or disable using <strong>Tools &gt; Send/Receive &gt; Global Address List.</strong>&lt;br&gt;• In Outlook 2010 onwards, enable or disable using <strong>Zimbra &gt; Sync Global Address List.</strong></td>
</tr>
<tr>
<td>Select/Deselect Error Messages</td>
<td>• In Outlook 2003/07, select or deselect error messages to the Inbox. Go to <strong>View &gt; Errors to Inbox.</strong>&lt;br&gt;• In Outlook 2010 onwards, select or deselect error messages to the Inbox. Go to <strong>Zimbra &gt; Error Reports &gt; Save in Inbox.</strong></td>
</tr>
<tr>
<td>Sharing</td>
<td>Users can access Zimbra mail folders, calendars, contacts, and tasks shared by another Zimbra user.</td>
</tr>
</tbody>
</table>
Personal Email Certificates (S/MIME)

Personal Email Certificates (S/MIME) synchronize in the GAL from Zimbra Collaboration, which allows users to send and receive signed and encrypted email messages. Certificates are stored in two places, including the GAL (synchronized to ZCO during GAL sync), and in Personal Contacts (synchronized bi-directionally with Zimbra Collaboration).

Advanced Settings

Users can modify the following advanced settings from the Advanced button, available from:

- In Outlook 2003/07, go to View > Toolbars > Zimbra Support
- In Outlook 2010 onwards, go to Zimbra > Advanced

**Note:** Any changes made in the Advanced Settings dialog are made to the registry.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connection Timeouts.</td>
<td>Configure HTTP connection settings. The default settings for connect, send, receive and option/receive are 900000 milliseconds, or 15 minutes. These settings are configurable.</td>
</tr>
<tr>
<td>GAL Sync Optimizations</td>
<td>Set GAL sync time, including sleep time, and sleep after. If the user’s system is slow due to the sync, they can configure their system to go to sleep after a specified number of contacts have been synced.</td>
</tr>
<tr>
<td>LDAP</td>
<td>The LDAP default is disable. Users can enable LDAP and enter the server name.</td>
</tr>
<tr>
<td>Delegate Calendar Sync</td>
<td>Select to sync all calendar content, or select to sync partial calendar content by selecting a specified number of days to sync.</td>
</tr>
<tr>
<td>Enable local rules</td>
<td>Check this box to allow users to enable local Outlook rules. By default, local Outlook rules are disabled.</td>
</tr>
<tr>
<td>Store password in the profile</td>
<td>Check this box for users to store their passwords in their profiles. Uncheck this box if you do not want user passwords stored in their profile. They enter their password at each login.</td>
</tr>
<tr>
<td>Synchronize Signatures</td>
<td>Check this box to sync email signatures from Outlook’s “Signatures and Stationary” dialog with the server.</td>
</tr>
<tr>
<td>Synchronize Preferences</td>
<td>Check this box to allow preferences, such as Read Receipt options in Outlook’s Options dialog, to sync with the server.</td>
</tr>
</tbody>
</table>
### Zimbra Feature Differences for Outlook Users

This section includes some information about feature differences for Outlook users who are now using ZCO.

#### Free/Busy Lookup in ZCO

If the Zimbra Collaboration server CA certificate is self-signed, free/busy lookup in Outlook fails with the error "An error occurred reading Internet free/busy data. General failure." To fix this issue, add the CA certificate to Internet Explorer’s Trusted Root Certification Authorities.

#### Outlook AutoArchive Disabled for Zimbra Profiles and Folders

The Outlook AutoArchive function is disabled for Zimbra profiles and folders. This feature should not be enabled. Auto-archiving removes files from the server, including items shared with others. This can cause data loss or problems with recurring appointments, shared items, and historical calendar data.

**Note:** Outlook’s global AutoArchive function remains enabled for Outlook features that are not Zimbra specific.

#### Forwarding Invitations

If you forward a meeting invitation to another user, a notification is sent to the original meeting organizer because you have now extended their invitation to a new invitee.
5 Troubleshooting ZCO

Topics in this chapter include:

- Troubleshooting Overview on page 23
- Received a Local/Server Failure Notice on page 24
- Reviewing Sync Issues folders on page 24
- Enabling Logging on page 25
- When Outlook Crashes on page 26
- When Outlook Hangs on page 26
- My Zimbra Calendar will not Sync on page 26
- Unable to Access a Shared Item on page 26
- The .zdb File is Corrupt on page 26
- Conflict with Antivirus Software or other Outlook Add-ins on page 26
- Repairing ZCO on page 27
- Removing ZCO on page 27
- Resolving Mailbox Sync Problems on page 27
- Resyncing GAL for Contact Group Support on page 27
- Zimbra Support Toolbar and Zimbra Ribbon on page 28
- Zimbra Support and Additional Resources on page 29

Troubleshooting Overview

ZCO includes troubleshooting aids:

- **Failure Notices**: If ZCO has difficulty synchronizing a particular item it places a Failure Notice message in the Outlook’s Inbox or Sync Issues folder.

- **ZCO Logging**: ZCO can be configured to write detailed logs of an Outlook session.

- **Core Dumps**: In the event of a crash, ZCO automatically generates a core dump which can be analyzed by the support team.
Occasionally, conflicts can occur during installation, so if this is a new installation that has never functioned correctly, consider uninstalling ZCO, rebooting and reinstalling.

Conflicts can also arise between ZCO and Outlook Addins. It is suggested to review if the issue is reproducible after disabling the addins.

**Received a Local/Server Failure Notice**

If errors occur when Outlook syncs with Zimbra Collaboration (for example, a MIME error), Local/Server Failure messages are automatically sent to the user’s Outlook account.

Review the Failure messages. The problem might be apparent and simple to resolve, such as an “out of quota” message. If you cannot resolve the error based on the message, submit the messages with a support case to Zimbra Support.

When ZCO is installed, a Sync Issues folder with subfolders are created in the user’s Outlook Folder List. Copies of the Local/Server Failure messages is saved to the Sync Issues folder.

Users can tell when new messages are in a folder when the folder is bold and the number of unread messages is displayed beside the folder name.

To disable failure notifications to the user’s Inbox in the user’s Outlook:

- In Outlook 2003/07, deselect View > Errors to Inbox
- In Outlook 2010 onwards, deselect Zimbra > Error reports > uncheck Save In Inbox

**Reviewing Sync Issues folders**

When ZCO is installed, a Sync Issues folder with subfolders is created in the user’s Outlook Folder List. If errors are found when Outlook syncs with the server, a sync failure notification is sent to both the user’s Inbox and the Sync Issues folder. To turn off local failure notifications to the user’s Inbox:

- In Outlook 2003/07, deselect View > Errors to Inbox.
- In Outlook 2010 onwards, deselect Zimbra > Error reports > Save In Inbox

To view the Sync Issues folder, click the Folder List icon in the Outlook Navigation Pane. The Sync Issues folder is displayed in the Folder List. Users can tell when new messages are in these folders when the folder is bold and the number of unread messages is displayed.

If users are having problems using Outlook and continuously receiving errors, the messages in these folders should be submitted with a support case to Zimbra Support. These messages are created to help Zimbra technical support and engineering debug and fix errors.
Enabling Logging

ZCO generates a short summary log (with a filename ending in SUMMARY.log) every time Outlook runs. You can enable more detailed logging using one of the following:

- Select the Logging button on the Zimbra Support Toolbar (2003/07) or Zimbra Ribbon (2010 onwards) and select **Enabled**.
- Start > Run > zcologctl.exe <enter>
- Locate ZCLogCtl.exe in \Program files\Common Files\System\MSMAPI\<LCID> where LCID refers to the local ID of the user. For USA English, this ID is 1033
- In ZCLogCtl select **Enable Logging**.

All logs are written to a folder called ZCLogs in the path specified. The Advanced button hides some detailed options which should not be modified unless your support engineer advises you otherwise.

Some general tips for capturing effective troubleshooting information for Zimbra Support include:

1. Disable Windows Search to avoid capturing unnecessary logging
   start > run > services > Windows Search > Properties > Stop + “Disabled”
2. Disable foreign add-ins
3. Empty ZCLogs directory to ensure that only logs which span the reproduction of the problem remain in ZCLogs
4. Start Outlook and reproduce the issue
   a. Take detailed notes of the steps: times, ZimbraIDs, subjects, etc.
   b. Take screen shots, or a screen video if possible

Log files are generally intended for support engineers, but you might be able to review simple problems (such as lack of server connection) yourself by opening the log file and searching for ##ERROR## or ##WARNING##.
When Outlook Crashes

If Outlook closes unexpectedly (for example, with the warning “Outlook...needs to close”), look in the ZCOLogs directory for core dumps indicated as *.DMP files.

When Outlook Hangs

When Outlook hangs, Zimbra Support might ask you for a hang-dump. The easiest way to generate a hang-dump is to right click on OUTLOOK.EXE on Task Manager’s Processes tab and choose Create Dump File.

My Zimbra Calendar will not Sync

1. Verify that the user’s account has synced.
2. Check Local/Server Failure messages in the Sync Issues folders.
3. Submit a case with the logging information to Zimbra Support.

Unable to Access a Shared Item

1. Verify that the user has accessed the calendar correctly:
   a. Open > File > Other User’s Mailbox. The GAL is displayed.
   b. Select the sharing user from the list. The shared item should sync automatically.
2. Submit a case with the logging information to Zimbra Support.

The .zdb File is Corrupt

A user receives a Local Failure message stating that the .zdb file is corrupt. To fix this issue, you must repair the .zdb file. The .zdb file includes all Outlook data from Zimbra Collaboration in .pst format: messages, contacts, appointments, tasks, etc.

Use the scanpst.exe tool to repair any .zdb file that Outlook/ZCO has trouble opening.

Conflict with Antivirus Software or other Outlook Add-ins

It is not uncommon for ZCO to encounter problems when running third-party Outlook add-ins or antivirus software. Try disabling the add-ins before retrying to use ZCO. To report the problem, log a bug with Zimbra, list all of the Outlook add-ins that are installed, and indicate the add-ins you think are causing the conflict.
Troubleshooting ZCO

Repairing ZCO

1. Locate the ZCO .msi used to install ZCO and download the file to your computer.
2. Click the file to open.

**Note:** To find out which version of ZCO is installed, open Outlook and go to:
- For Outlook 2003/07 go to Help > About Zimbra Connector for Outlook.
- For Outlook 2010 onwards go to Zimbra > About Zimbra.

When the .msi file is opened after ZCO is installed, it opens with the options to repair the connector.
3. Click repair. ZCO is reinstalled.

Removing ZCO

To remove ZCO, including removing all components except the Zimbra profiles, on your computer go to Add or Remove Programs and select to remove Zimbra Connector for Microsoft Outlook.

Resolving Mailbox Sync Problems

If a user’s mailbox cannot receive new mail, becomes out-of-sync, or the .zdb file becomes corrupted, you can:

- Force an initial sync of the user’s mailbox. To do this, have the user create another profile, open Outlook and select the following to sync with Zimbra Collaboration.
  - For Outlook 2003/07 go to Tools > Send/Receive > Send/Receive All
  - For Outlook 2010 onwards go to Send/Receive > Send/Receive All Folders
- Set the Sync Token to an earlier number and resync the user’s mailbox. For more information, see Set Sync Token on page 28.

In some cases, it might be necessary to uninstall the .msi file, delete the profile and .zdb, and start over.

Resyncing GAL for Contact Group Support

For contact group support, perform a full GAL reset on your ZCO client to ensure contact groups and their members are synced correctly with ZCS.

- For Outlook 2003/07 go to Tools > Send/Receive > Global Address List> Reset Global Address List
- For Outlook 2010 onwards go to Zimbra > Sync Global Address List > Reset Global Address List
Zimbra Support Toolbar and Zimbra Ribbon

When ZCO is installed, the Zimbra Support Toolbar is added to the Outlook Views list. With later Outlook versions these options appear in the Support section of the Zimbra ribbon. If users are having issues with specific emails or folders, you can use this toolbar to collect information to help debug the issue.

To display the Zimbra Support Toolbar, select View > Toolbars > Zimbra Support.

The Zimbra Support Toolbar buttons are explained below.

View MAPI Properties

The View MAPI Properties button shows a subset of the MAPI properties of an item. Select either Message or Folder in the bottom left of the MAPI properties dialog to view MAPI properties of a message and of the folder. You can click Save to File to save the MAPI properties of an item to a file.

Open Original Source

The Open Original button opens the source of the original item in the default Internet browser. The browser prompts you for the account login information before you can view the item. The source text includes the Zimbra Item ID, Folder ID, and any other information contained in the original item (such as tags, flags, header information, etc.).

View IDs of Zimbra Activities

The View IDs of Zimbra Activities button allows you to view an email, appointment, task or other item in Outlook by its Zimbra Id. You can find the Zimbra Id of an item by using the Show Original button in the Zimbra Support Toolbar, or by the number listed in a Local Failure Notice.

Note: Meeting requests cannot be opened by Zimbra Id. Drafts can be opened, but sometimes generate errors when opened by Zimbra Id.

Set Sync Token

The Set Sync Token button allows you to set the Zimbra sync token. Sync tokens track the syncs between an Outlook client and Zimbra Collaboration. Sync tokens increase in numerical value between one sync and the next. Setting a sync token to an earlier number allows you to resync any items that failed to sync between the sync token you set and the current sync token.

For example, if an appointment fails to sync to a user’s Outlook client they receive a Local Failure Notice in their Inbox and Sync Issues > Local Failures folders.

To resync an item and update the user’s Outlook client with the most information, the Sync Token must be set to before the request that failed.
Note: In some cases, sync failures might not be resolved unless the Sync Token number is set back several tokens before the failed sync.

To set the sync token and attempt to resync an item that failed to sync, click Set Sync Token in the Zimbra Support Toolbar. The Update Sync Token dialog opens.

Enter the sync token to set. Click OK. To attempt to resync the item, click Send/Receive.

Zimbra Support and Additional Resources

If your issue is not a known or common issue, or is persisting despite troubleshooting, you can use the following additional resources to search for information about your issue or contact Zimbra Support for help.

Additional Resources

- **Zimbra Forums.** The Zimbra Forums, [http://community.zimbra.com](http://community.zimbra.com), are a great place to find answers to problems and issues you may be experiencing.


- **Web Search.** If you cannot find a solution to your issue through the Zimbra Forums, you might be able to find other resources or information using a Web search.

Contact Zimbra Support

You can contact Zimbra Support at support@zimbra.com. To provide the highest level of service, gather the following information before contacting support.

- Detailed description of the problem.

- Steps for reproducing the problem.

- Zimbra Support Toolbar output. You need to include any relevant Zimbra Support Toolbar output, described in Zimbra Support Toolbar and Zimbra Ribbon on page 28.

- Logs that span the problem.

- Crash Dumps. These are generated automatically if Outlook crashes.
  - For ZCO 8.5.0 and later, crash dump logs are generated in ZCOLogs.
  - For ZCO 8.0.7 and prior, crash dump logs generated in %temp%\zcocores or ZCOLogs.

- Hang Dumps
Beyond the above information, include the following information if it is relevant to your problem.

- **Install logs.** If users are experiencing issues with installing ZCO, include the install logs. You can create install logs by running the following command:
  
  `msiexec /i <zco-installer.msi> /lv <zco-install.log>`

  For example, the following command creates a ZCO install log named `case0012345-zco-install.log`.

  `msiexec /i ZimbraOlkConnector-5.0.6_GA_2314_5.0.2635.6.msi /lv case0012345-zco-install.log`

- **Sync error messages.** If users are experiencing issues with syncing, include any relevant error messages. You can find sync error messages in the Local Failures and Server Failures folders, located in the Sync Issues mail folder. For more information about the Sync Issues folder, see [Reviewing Sync Issues folders](#) on page 24.